New Search

Windows Elevation of Privilege Vulnerability - CVE-2019-1215

oval:org.cisecurity:def:6568

An elevation of privilege vulnerability exists in the way that ws2ifsl.sys (Winsock) handles objects in memory. An attacker who successfully exploited the vulnerability could execute code with elevated privileges. To exploit the vulnerability a locally authenticated attacker could run a specially crafted application. The security update addresses the vulnerability by ensuring that ws2ifsl.sys properly handles objects in memory.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008
  • Microsoft Windows 7
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows 8.1
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2019
Class:
vulnerability
Reference(s):
  • CVE-2019-1215
  • MSRC-CVE-2019-1215
  • KB4516033
  • KB4516051
  • KB4516062
  • KB4516064
  • KB4516070
  • KB4516044
  • KB4516068
  • KB4516066
  • KB4516058
  • KB4512578
  • KB4515384
Product(s):