New Search

Component Object Model Elevation of Privilege Vulnerability - CVE-2020-1311

oval:org.cisecurity:def:7761

An elevation of privilege vulnerability exists when Component Object Model (COM) client uses special case IIDs. An attacker who successfully exploited this vulnerability could run arbitrary code with elevated system privileges. An attacker could then install programs; view change or delete data; or create new accounts with full user rights. To exploit this vulnerability an attacker would have to log on to an affected system and run a specially crafted application. The security update addresses the vulnerability by correcting how COM handles special case IIDs to help preclude unintended elevated system privileges.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2012
  • Microsoft Windows 8.1
  • Microsoft Windows 7
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2019
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012 R2
Class:
vulnerability
Reference(s):
  • CVE-2020-1311
  • MSRC-CVE-2020-1311
  • KB4561669
  • KB4561674
  • KB4561673
  • KB4561649
  • KB4561616
  • KB4561602
  • KB4561621
  • KB4561608
  • KB4560960
Product(s):