New Search

Vulnerability in PostgreSQL 10.x before 10.4 9.6.x before 9.6.9 (CVE-2018-1115)

oval:org.cisecurity:def:8181

postgresql before versions 10.4 9.6.9 is vulnerable in the adminpack extension the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database an attacker able to connect to it could exploit this to force log rotation.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows 8.1
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows Vista
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows XP
  • Microsoft Windows Server 2012 R2
Class:
vulnerability
Reference(s):
  • CVE-2018-1115
Product(s):
  • PostgreSQL