New Search

Vulnerability in PostgreSQL 11.x before 11.3 10.xbefore 10.8 9.6.x before 9.6.13 9.5.x before 9.5.17 (CVE-2019-10130)

oval:org.cisecurity:def:8196

A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3 10.x up to excluding 10.8 9.6.x up to excluding 9.6.13 9.5.x up to excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics such as histograms and lists of most common values contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which in an ordinary query row-level security prunes the set of rows visible to the attacker.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows 8
  • Microsoft Windows 10
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2016
  • Microsoft Windows 8.1
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows XP
  • Microsoft Windows Server 2012
Class:
vulnerability
Reference(s):
  • CVE-2019-10130
Product(s):
  • PostgreSQL