New Search

Vulnerability in PostgreSQL 8.4.x before 8.4.11 9.0.x before 9.0.7 and 9.1.x before 9.1.3 (CVE-2012-0867)

oval:org.cisecurity:def:8205

PostgreSQL 8.4.x before 8.4.11 9.0.x before 9.0.7 and 9.1.x before 9.1.3 truncates the common name to only 32 characters when verifying SSL certificates which allows remote attackers to spoof connections when the host name is exactly 32 characters.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows 8.1
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows Vista
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows XP
  • Microsoft Windows Server 2012 R2
Class:
vulnerability
Reference(s):
  • CVE-2012-0867
Product(s):
  • PostgreSQL