New Search

Vulnerability in PostgreSQL before 9.0.23 9.1.x before 9.1.19 9.2.x before 9.2.14 9.3.x before 9.3.10 and 9.4.x before 9.4.5 (CVE-2015-5288)

oval:org.cisecurity:def:8208

The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23 9.1.x before 9.1.19 9.2.x before 9.2.14 9.3.x before 9.3.10 and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a "too-short" salt.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows 8.1
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows 8
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows 7
Class:
vulnerability
Reference(s):
  • CVE-2015-5288
Product(s):
  • PostgreSQL