New Search

Vulnerability in Postgresql versions before 10.5 9.6.10 9.5.14 9.4.19 and 9.3.24 (CVE-2018-10915)

oval:org.cisecurity:def:8227

A vulnerability was found in libpq the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input attackers could bypass client-side connection security features obtain access to higher privileged connections or potentially cause other impact through SQL injection by causing the PQescape() functions to malfunction. Postgresql versions before 10.5 9.6.10 9.5.14 9.4.19 and 9.3.24 are affected.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2012
  • Microsoft Windows 8.1
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows Vista
  • Microsoft Windows Server 2016
  • Microsoft Windows 10
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows XP
  • Microsoft Windows Server 2012 R2
Class:
vulnerability
Reference(s):
  • 105054
  • CVE-2018-10915
Product(s):
  • PostgreSQL