New Search

Multiple vulnerabilities on Acrobat DC Continuous and Acrobat Reader DC Continuous versions 2021.001.20150 and earlier Acrobat 2020 and Acrobat Reader 2020 versions 2020.001.30020 and earlier versions Acrobat 2017 and Acrobat Reader 2017 versions 2017.011.30194 and earlier

oval:org.cisecurity:def:8777

Buffer overflow that could lead to arbitrary code execution. (CVE-2021-28561) Heap-based buffer overflow that could lead to arbitrary code execution. (CVE-2021-28560 CVE-2021-28558) Out-of-bounds read that could lead to memory leak. (CVE-2021-28557) Out-of-bounds read that could lead to arbitrary file system read. (CVE-2021-28555) Out-of-bounds read that could lead to arbitrary code execution. (CVE-2021-28564) Out-of-bounds write that could lead to arbitrary code execution. (CVE-2021-28565) Acrobat Reader DC versions versions 2020.013.20074 (and earlier) 2020.001.30018 (and earlier) and 2017.011.30188 (and earlier) are affected by an Out-of-bounds Write vulnerability when parsing a crafted jpeg file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2021-21044 CVE-2021-21038) Out-of-bounds write that could lead to arbitrary code execution. (CVE-2021-21086) Exposure of private information that could lead to privilege escalation. (CVE-2021-28559) Use after tree that could lead to arbitrary code execution. (CVE-2021-28562 CVE-2021-28550 CVE-2021-28553)

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows 8
  • Microsoft Windows 10
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows 8.1
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
Class:
vulnerability
Reference(s):
  • APSB21-29
  • CVE-2021-28561
  • CVE-2021-28560
  • CVE-2021-28558
  • CVE-2021-28557
  • CVE-2021-28555
  • CVE-2021-28564
  • CVE-2021-28565
  • CVE-2021-21044
  • CVE-2021-21038
  • CVE-2021-21086
  • CVE-2021-28559
  • CVE-2021-28562
  • CVE-2021-28550
  • CVE-2021-28553
Product(s):
  • Adobe Acrobat 2020
  • Adobe Reader 2020
  • Adobe Reader 2017
  • Adobe Reader DC Continuous
  • Adobe Acrobat DC Continuous
  • Adobe Acrobat 2017