New Search

CVS serve_notify Improper Handling of Empty Data Lines

oval:org.mitre.oval:def:1003

serve_notify in CVS 1.12.x through 1.12.8 and 1.11.x through 1.11.16 does not properly handle empty data lines which may allow remote attackers to perform an "out-of-bounds" write for a single byte to execute arbitrary code or modify critical program data.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • Red Hat Enterprise Linux 3
Class:
vulnerability
Reference(s):
  • CVE-2004-0418
Product(s):
  • CVS