New Search

Array index error in the make_table function in unlzh.c in the LZH decompression component in gzip 1.3.5 when running on certain platforms allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted GZIP archive that triggers an out-of-bounds write aka a "stack modification vulnerability."

oval:org.mitre.oval:def:10391

Array index error in the make_table function in unlzh.c in the LZH decompression component in gzip 1.3.5 when running on certain platforms allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted GZIP archive that triggers an out-of-bounds write aka a "stack modification vulnerability."

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 4
  • Red Hat Enterprise Linux 3
  • Red Hat Enterprise Linux 4
  • Oracle Linux 4
  • CentOS Linux 3
Class:
vulnerability
Reference(s):
  • CVE-2006-4335
Product(s):