New Search

gfs2 in the Linux kernel 2.6.18 and possibly other versions does not properly handle when the gfs2_quota struct occupies two separate pages which allows local users to cause a denial of service (kernel panic) via certain manipulations that cause an out-of-bounds write as demonstrated by writing from an ext3 file system to a gfs2 file system.

oval:org.mitre.oval:def:10652

gfs2 in the Linux kernel 2.6.18 and possibly other versions does not properly handle when the gfs2_quota struct occupies two separate pages which allows local users to cause a denial of service (kernel panic) via certain manipulations that cause an out-of-bounds write as demonstrated by writing from an ext3 file system to a gfs2 file system.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • Oracle Linux 5
  • CentOS Linux 5
  • Red Hat Enterprise Linux 5
Class:
vulnerability
Reference(s):
  • CVE-2010-1436
Product(s):