New Search

The GENERATE_SEED macro in PHP 4.x before 4.4.8 and 5.x before 5.2.5 when running on 64-bit systems performs a multiplication that generates a portion of zero bits during conversion due to insufficient precision which produces 24 bits of entropy and simplifies brute force attacks against protection mechanisms that use the rand and mt_rand functions.

oval:org.mitre.oval:def:10844

The GENERATE_SEED macro in PHP 4.x before 4.4.8 and 5.x before 5.2.5 when running on 64-bit systems performs a multiplication that generates a portion of zero bits during conversion due to insufficient precision which produces 24 bits of entropy and simplifies brute force attacks against protection mechanisms that use the rand and mt_rand functions.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 4
  • CentOS Linux 3
  • Red Hat Enterprise Linux 5
  • Oracle Linux 4
  • Oracle Linux 5
  • Red Hat Enterprise Linux 3
  • Red Hat Enterprise Linux 4
  • CentOS Linux 5
Class:
vulnerability
Reference(s):
  • CVE-2008-2108
Product(s):