New Search

ext/openssl/ossl_ocsp.c in Ruby 1.8 and 1.9 does not properly check the return value from the OCSP_basic_verify function which might allow remote attackers to successfully present an invalid X.509 certificate possibly involving a revoked certificate.

oval:org.mitre.oval:def:11450

ext/openssl/ossl_ocsp.c in Ruby 1.8 and 1.9 does not properly check the return value from the OCSP_basic_verify function which might allow remote attackers to successfully present an invalid X.509 certificate possibly involving a revoked certificate.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • Red Hat Enterprise Linux 4
  • Oracle Linux 5
  • CentOS Linux 4
  • CentOS Linux 5
  • Oracle Linux 4
  • Red Hat Enterprise Linux 5
Class:
vulnerability
Reference(s):
  • CVE-2009-0642
Product(s):