New Search

Adobe Shockwave Player Memory Corruption Vulnerability

oval:org.mitre.oval:def:11554

DIRAPIX.dll in Adobe Shockwave Player before 11.5.8.612 does not properly validate a certain chunk size in the mmap chunk in a Director movie which allows remote attackers to cause a denial of service (heap memory corruption) or execute arbitrary code via a crafted movie.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 2000
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2010-2870
Product(s):
  • Adobe Shockwave Player