New Search

Adobe Reader and Acrobat CoolType.dll Font Parsing Buffer Overflow Vulnerability

oval:org.mitre.oval:def:11586

Stack-based buffer overflow in CoolType.dll in Adobe Reader and Acrobat 9.x before 9.4 and 8.x before 8.2.5 on Windows and Mac OS X allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a PDF document with a long field in a Smart INdependent Glyphlets (SING) table in a TTF font as exploited in the wild in September 2010. NOTE: some of these details are obtained from third party information.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 2000
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2010-2883
Product(s):
  • Adobe Reader
  • Adobe Acrobat