New Search

Ruby 1.8.5 and earlier 1.8.6 through 1.8.6-p286 1.8.7 through 1.8.7-p71 and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels which allows context-dependent attackers to bypass intended access restrictions via (1) untrace_var (2) $PROGRAM_NAME and (3) syslog at safe level 4 and (4) insecure methods at safe levels 1 through 3.

oval:org.mitre.oval:def:11602

Ruby 1.8.5 and earlier 1.8.6 through 1.8.6-p286 1.8.7 through 1.8.7-p71 and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels which allows context-dependent attackers to bypass intended access restrictions via (1) untrace_var (2) $PROGRAM_NAME and (3) syslog at safe level 4 and (4) insecure methods at safe levels 1 through 3.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 3
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 4
  • CentOS Linux 5
  • Oracle Linux 4
  • Red Hat Enterprise Linux 3
  • CentOS Linux 4
  • Oracle Linux 5
Class:
vulnerability
Reference(s):
  • CVE-2008-3655
Product(s):