New Search

Mozilla Firefox/Thunderbird/SeaMonkey 'libpng' Buffer Overflow Vulnerability

oval:org.mitre.oval:def:11851

Buffer overflow in pngpread.c in libpng before 1.2.44 and 1.4.x before 1.4.3 as used in progressive applications might allow remote attackers to execute arbitrary code via a PNG image that triggers an additional data row.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows 2000
  • Microsoft Windows Server 2008
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2010-1205
Product(s):
  • Mozilla Firefox
  • Mozilla Thunderbird
  • Mozilla SeaMonkey