New Search

Vulnerability in WebKit in Apple Safari before 5.0.3 versions

oval:org.mitre.oval:def:12293

The WebCore::HTMLLinkElement::process function in WebCore/html/HTMLLinkElement.cpp in WebKit as used in Apple Safari before 5.0.3 on Mac OS X 10.5 through 10.6 and Windows and before 4.1.3 on Mac OS X 10.4; webkitgtk before 1.2.6; and possibly other products does not verify whether DNS prefetching is enabled when processing an HTML LINK element which allows remote attackers to bypass intended access restrictions as demonstrated by an HTML e-mail message that uses a LINK element for X-Confirm-Reading-To functionality.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows 2000
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
Class:
vulnerability
Reference(s):
  • CVE-2010-3813
Product(s):
  • Apple Safari