New Search

Vulnerability in the Standard PHP Library (SPL) extension in PHP before 5.3.4

oval:org.mitre.oval:def:12334

The SplFileInfo::getType function in the Standard PHP Library (SPL) extension in PHP before 5.3.4 on Windows does not properly detect symbolic links which might make it easier for local users to conduct symlink attacks by leveraging cross-platform differences in the stat structure related to lack of a FILE_ATTRIBUTE_REPARSE_POINT check.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows 2000
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
Class:
vulnerability
Reference(s):
  • CVE-2011-0754
Product(s):
  • PHP