New Search

.NET Framework Class Inheritance Vulnerability

oval:org.mitre.oval:def:13069

Microsoft .NET Framework 1.0 SP3 1.1 SP1 2.0 SP2 3.5.1 and 4 and Silverlight 4 before 4.0.60831 does not properly restrict inheritance which allows remote attackers to execute arbitrary code via (1) a crafted XAML browser application (aka XBAP) (2) a crafted ASP.NET application (3) a crafted .NET Framework application or (4) a crafted Silverlight application aka ".NET Framework Class Inheritance Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2008 R2
Class:
vulnerability
Reference(s):
  • CVE-2011-1253
Product(s):
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 4
  • Microsoft .NET Framework 1.0
  • Microsoft .NET Framework 3.5.1
  • Microsoft .NET Framework 2.0
  • Microsoft Silverlight 4