New Search

Plug and Play User Data Validation Vulnerability (WinXPSP1)

oval:org.mitre.oval:def:1328

Stack-based buffer overflow in the Plug and Play (PnP) service (UMPNPMGR.DLL) in Microsoft Windows 2000 SP4 and XP SP1 and SP2 allows remote or local authenticated attackers to execute arbitrary code via a large number of "\" (backslash) characters in a registry key name which triggers the overflow in a wsprintfW function call.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2005-2120
Product(s):