New Search

The JSSubScriptLoader in Mozilla Firefox 4.x through 6 and SeaMonkey before 2.4 does not properly handle XPCNativeWrappers during calls to the loadSubScript method in an add-on which makes it easier for remote attackers to gain privileges via a crafted web site that leverages certain unwrapping behavior.

oval:org.mitre.oval:def:14121

The JSSubScriptLoader in Mozilla Firefox 4.x through 6 and SeaMonkey before 2.4 does not properly handle XPCNativeWrappers during calls to the loadSubScript method in an add-on which makes it easier for remote attackers to gain privileges via a crafted web site that leverages certain unwrapping behavior.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 2000
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows Vista
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2011-3004
Product(s):
  • Mozilla Seamonkey
  • Mozilla Firefox