New Search

Use-after-free vulnerability in Mozilla Firefox 4.x through 10.0 Firefox ESR 10.x before 10.0.3 Thunderbird 5.0 through 10.0 Thunderbird ESR 10.x before 10.0.3 and SeaMonkey before 2.8 on 32-bit Windows 7 platforms allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors involving use of the file-open dialog in a child window related to the IUnknown_QueryService function in the Windows shlwapi.dll library.

oval:org.mitre.oval:def:14258

Use-after-free vulnerability in Mozilla Firefox 4.x through 10.0 Firefox ESR 10.x before 10.0.3 Thunderbird 5.0 through 10.0 Thunderbird ESR 10.x before 10.0.3 and SeaMonkey before 2.8 on 32-bit Windows 7 platforms allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors involving use of the file-open dialog in a child window related to the IUnknown_QueryService function in the Windows shlwapi.dll library.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
Class:
vulnerability
Reference(s):
  • CVE-2012-0454
Product(s):
  • Mozilla Thunderbird ESR
  • Mozilla Firefox
  • Mozilla Thunderbird
  • Mozilla Seamonkey
  • Mozilla Firefox ESR