New Search

Nullsoft Winamp before 5.24 does not properly verify the authenticity of updates

oval:org.mitre.oval:def:15225

Nullsoft Winamp before 5.24 does not properly verify the authenticity of updates which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update as demonstrated by evilgrade and DNS cache poisoning.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows Server 2008
  • Microsoft Windows 2000
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2008-3441
Product(s):
  • Winamp