New Search

Adobe Flash Player Invalid Object Reference Remote Code Execution

oval:org.mitre.oval:def:16057

Adobe Flash Player 9.x before 9.0.159.0 and 10.x before 10.0.22.87 does not properly remove references to destroyed objects during Shockwave Flash file processing which allows remote attackers to execute arbitrary code via a crafted file related to a "buffer overflow issue."

Family:
macos
Status:
ACCEPTED
Platform(s):
  • Apple Mac OS X
Class:
vulnerability
Reference(s):
  • CVE-2009-0520
Product(s):
  • Adobe Flash Player