New Search

Apple iTunes before 10.5.1 does not properly verify the authenticity of updates which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update as demonstrated by evilgrade and DNS cache poisoning

oval:org.mitre.oval:def:17136

Apple iTunes before 10.5.1 does not properly verify the authenticity of updates which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update as demonstrated by evilgrade and DNS cache poisoning.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows 7
  • Microsoft Windows 2000
  • Microsoft Windows Server 2008
  • Microsoft Windows 8
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2012
Class:
vulnerability
Reference(s):
  • CVE-2008-3434
Product(s):
  • Apple iTunes