New Search

Windows Animated Cursor Remote Code Execution Vulnerability

oval:org.mitre.oval:def:1854

Stack-based buffer overflow in the animated cursor code in Microsoft Windows 2000 SP4 through Vista allows remote attackers to execute arbitrary code or cause a denial of service (persistent reboot) via a large length value in the second (or later) anih block of a RIFF .ANI cur or .ico file which results in memory corruption when processing cursors animated cursors and icons a variant of CVE-2005-0416 as originally demonstrated using Internet Explorer 6 and 7. NOTE: this might be a duplicate of CVE-2007-1765; if so then CVE-2007-0038 should be preferred.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • Microsoft Windows 2000
Class:
vulnerability
Reference(s):
  • CVE-2007-0038
Product(s):