New Search

SMB Code Execution Vulnerability (XPSP1)

oval:org.mitre.oval:def:1889

The Server Message Block (SMB) implementation for Windows NT 4.0 2000 XP and Server 2003 does not properly validate certain SMB packets which allows remote attackers to execute arbitrary code via Transaction responses containing (1) Trans or (2) Trans2 commands aka the "Server Message Block Vulnerability" and as demonstrated using Trans2 FIND_FIRST2 responses with large file name length fields.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2005-0045
Product(s):
  • SMB (Server Message Block)