New Search

OpenSSL vulnerability before 0.9.8q and 1.0.x before 1.0.0c in VisualSVN Server (CVE-2010-4180)

oval:org.mitre.oval:def:18910

OpenSSL before 0.9.8q and 1.0.x before 1.0.0c when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled does not properly prevent modification of the ciphersuite in the session cache which allows remote attackers to force the downgrade to an unintended cipher via vectors involving sniffing network traffic to discover a session identifier.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows 8
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2008
  • Microsoft Windows 7
  • Microsoft Windows Server 2012
Class:
vulnerability
Reference(s):
  • CVE-2010-4180
Product(s):
  • VisualSVN Server