New Search

IE v6.0SP1 Function Pointer Override Cross Domain Vulnerability

oval:org.mitre.oval:def:357

Internet Explorer 6 SP1 and earlier allows remote attackers to bypass zone restrictions and read arbitrary files by (1) modifying the createTextRange method and using CreateLink as demonstrated using LinkillerSaveRef LinkillerJPU and Linkiller or (2) modifying the createRange method and using the FIND dialog to select text as demonstrated using Findeath aka the "Function Pointer Override Cross Domain" vulnerability.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows ME
  • Microsoft Windows XP
  • Microsoft Windows NT
  • Microsoft Windows 2000
Class:
vulnerability
Reference(s):
  • CVE-2003-0815
Product(s):
  • Microsoft Internet Explorer