New Search

A Security Vulnerability in the OpenSSL PKCS#11 Engine May Result in Denial of Service (DoS) Due to a Corrupted Session Cache

oval:org.mitre.oval:def:5914

The PK11_SESSION cache in the OpenSSL PKCS#11 engine in Sun Solaris 10 does not maintain reference counts for operations with asymmetric keys which allows context-dependent attackers to cause a denial of service (failed cryptographic operations) via unspecified vectors related to the (1) RSA_sign and (2) RSA_verify functions.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • Sun Solaris 10
Class:
vulnerability
Reference(s):
  • CVE-2008-5410
Product(s):