New Search

Memory Corruption Vulnerability

oval:org.mitre.oval:def:6043

Microsoft Office Excel 2000 SP3 2002 SP3 2003 SP3 and 2007 SP1; Excel in Microsoft Office 2004 and 2008 for Mac; Microsoft Office Excel Viewer and Excel Viewer 2003 SP3; and Microsoft Office Compatibility Pack for Word Excel and PowerPoint 2007 File Formats SP1 do not properly parse the Excel spreadsheet file format which allows remote attackers to execute arbitrary code via a crafted spreadsheet that contains a malformed object with "an offset and a two-byte value" that trigger a memory calculation error aka "Memory Corruption Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows Server 2008
  • Microsoft Windows 2000
  • Microsoft Windows XP
Class:
vulnerability
Reference(s):
  • CVE-2009-0100
Product(s):
  • Microsoft Excel 2003
  • Microsoft Office Excel Viewer
  • Microsoft Office Excel Viewer 2003
  • Microsoft Excel 2000
  • Microsoft Office Compatibility Pack
  • Microsoft Excel 2002
  • Microsoft Excel 2007