New Search

Mozilla Firefox before 3.0.14 allow remote arbitrary code execution Vulnerability

oval:org.mitre.oval:def:6140

Mozilla Firefox before 3.0.14 does not properly implement certain dialogs associated with the (1) pkcs11.addmodule and (2) pkcs11.deletemodule operations which makes it easier for remote attackers to trick a user into installing or removing an arbitrary PKCS11 module.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008
  • Microsoft Windows 8
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows 8.1
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2008 R2
Class:
vulnerability
Reference(s):
  • CVE-2009-3076
Product(s):
  • Mozilla Firefox