New Search

Microsoft .NET Framework Type Verification Vulnerability

oval:org.mitre.oval:def:6451

Microsoft .NET Framework 2.0 2.0 SP1 and 3.5 does not properly enforce a certain type-equality constraint in .NET verifiable code which allows remote attackers to execute arbitrary code via (1) a crafted XAML browser application (XBAP) (2) a crafted ASP.NET application or (3) a crafted .NET Framework application aka "Microsoft .NET Framework Type Verification Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows XP
  • Microsoft Windows 7
  • Microsoft Windows 2000
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
Class:
vulnerability
Reference(s):
  • CVE-2009-0091
Product(s):
  • Microsoft .NET Framework