New Search

Vim HelpTags Command Remote Format String Vulnerability

oval:org.mitre.oval:def:6463

Format string vulnerability in the helptags_one function in src/ex_cmds.c in Vim 6.4 and earlier and 7.x up to 7.1 allows user-assisted remote attackers to execute arbitrary code via format string specifiers in a help-tags tag in a help file related to the helptags command.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • VMWare ESX Server 3.5
  • VMWare ESX Server 3
Class:
vulnerability
Reference(s):
  • CVE-2007-2953
Product(s):