New Search

Sun Java Runtime Environment Java Plug-in Javascript code unauthorized access

oval:org.mitre.oval:def:6584

The Java Plug-in in Java SE Development Kit (JDK) and Java Runtime Environment (JRE) 5.0 Update 17 and earlier; 6 Update 12 and earlier; and 1.4.2_19 and earlier does not prevent Javascript that is loaded from the localhost from connecting to other ports on the system which allows user-assisted attackers to bypass intended access restrictions via LiveConnect aka CR 6724331. NOTE: this vulnerability can be leveraged with separate cross-site scripting (XSS) vulnerabilities for remote attack vectors.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • VMWare ESX Server 4.0
  • VMWare ESX Server 3.5
Class:
vulnerability
Reference(s):
  • CVE-2009-1104
Product(s):