New Search

Adobe Flash Player Invalid Object Reference Remote Code Execution

oval:org.mitre.oval:def:6593

Adobe Flash Player 9.x before 9.0.159.0 and 10.x before 10.0.22.87 does not properly remove references to destroyed objects during Shockwave Flash file processing which allows remote attackers to execute arbitrary code via a crafted file related to a "buffer overflow issue."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Vista
  • Microsoft Windows 2000
  • Microsoft Windows Server 2003
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
  • Microsoft Windows 7
Class:
vulnerability
Reference(s):
  • CVE-2009-0520
Product(s):
  • Adobe Flash Player
  • Adobe AIR