Definition


New Search

WebKit Malformed URL Handling Cross-site Scripting Vulnerability

oval:org.mitre.oval:def:6656

Cross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 5.0 on Mac OS X 10.5 through 10.6 and Windows and before 4.1 on Mac OS X 10.4 allows remote attackers to inject arbitrary web script or HTML via vectors related to a malformed URL.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows 7
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
Class:
vulnerability
Reference(s):
  • CVE-2010-0544
Product(s):
  • Apple Safari