New Search

Adobe Shockwave Player 3D Object Parsing Memory Corruption Vulnerability

oval:org.mitre.oval:def:7262

Adobe Shockwave Player before 11.5.7.609 does not properly parse 3D objects in .dir (aka Director) files which allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via a modified field in a 0xFFFFFF49 record.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2003
  • Microsoft Windows Vista
  • Microsoft Windows 7
Class:
vulnerability
Reference(s):
  • CVE-2010-1283
Product(s):
  • Adobe Shockwave Player