New Search

Comctl32 Heap Overflow Vulnerability

oval:org.mitre.oval:def:7272

Heap-based buffer overflow in Comctl32.dll (aka the common control library) in Microsoft Windows XP SP2 and SP3 Windows Server 2003 SP2 Windows Vista SP1 and SP2 Windows Server 2008 Gold SP2 and R2 and Windows 7 when a third-party SVG viewer is used allows remote attackers to execute arbitrary code via a crafted HTML document that triggers unspecified messages from this viewer aka "Comctl32 Heap Overflow Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Vista
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
  • Microsoft Windows 7
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Server 2003
Class:
vulnerability
Reference(s):
  • CVE-2010-2746
Product(s):