New Search

Linux kernel 'O_EXCL' NFSv4 Privilege Escalation Vulnerability

oval:org.mitre.oval:def:7527

NFSv4 in the Linux kernel 2.6.18 and possibly other versions does not properly clean up an inode when an O_EXCL create fails which causes files to be created with insecure settings such as setuid bits and possibly allows local users to gain privileges related to the execution of the do_open_permission function even when a create fails.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • VMWare ESX Server 4.0
Class:
vulnerability
Reference(s):
  • CVE-2009-3286
Product(s):