New Search

Mozilla Firefox and SeaMonkey window.navigator.plugins Object Dangling Pointer Vulnerability

oval:org.mitre.oval:def:7622

Mozilla Firefox before 3.0.19 3.5.x before 3.5.9 and 3.6.x before 3.6.2 and SeaMonkey before 2.0.4 frees the contents of the window.navigator.plugins array while a reference to an array element is still active which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via unspecified vectors related to a "dangling pointer vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008
  • Microsoft Windows Server 2003
  • Microsoft Windows 7
  • Microsoft Windows 2000
  • Microsoft Windows XP
  • Microsoft Windows Vista
Class:
vulnerability
Reference(s):
  • CVE-2010-0177
Product(s):
  • Mozilla SeaMonkey
  • Mozilla Firefox