Definition


New Search

VMware python multiple buffer overflows vulnerability

oval:org.mitre.oval:def:8422

Multiple buffer overflows in Python 2.5.2 and earlier on 32bit platforms allow context-dependent attackers to cause a denial of service (crash) or have unspecified other impact via a long string that leads to incorrect memory allocation during Unicode string processing related to the unicode_resize function and the PyMem_RESIZE macro.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • VMWare ESX Server 4.0
  • VMWare ESX Server 3.5
  • VMWare ESX Server 3
Class:
vulnerability
Reference(s):
  • CVE-2008-3142
Product(s):