New Search

VMware python zlib extension module vulnerability

oval:org.mitre.oval:def:8494

Integer signedness error in the zlib extension module in Python 2.5.2 and earlier allows remote attackers to execute arbitrary code via a negative signed integer which triggers insufficient memory allocation and a buffer overflow.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • VMWare ESX Server 3.5
  • VMWare ESX Server 3
  • VMWare ESX Server 4.0
Class:
vulnerability
Reference(s):
  • CVE-2008-1721
Product(s):