New Search

Apache 'Options' and 'AllowOverride' Directives Security Bypass Vulnerability

oval:org.mitre.oval:def:8704

The Apache HTTP Server 2.2.11 and earlier 2.2 versions does not properly handle Options=IncludesNOEXEC in the AllowOverride directive which allows local users to gain privileges by configuring (1) Options Includes (2) Options +Includes or (3) Options +IncludesNOEXEC in a .htaccess file and then inserting an exec element in a .shtml file.

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2003
  • Microsoft Windows 2000
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows XP
  • Microsoft Windows Server 2008
Class:
vulnerability
Reference(s):
  • CVE-2009-1195
Product(s):
  • Apache