New Search

The Linux kernel before 2.6.12.5 does not properly destroy a keyring that is not instantiated properly which allows local users or remote attackers to cause a denial of service (kernel oops) via a keyring with a payload that is not empty which causes the creation to fail leading to a null dereference in the keyring destructor.

oval:org.mitre.oval:def:9079

The Linux kernel before 2.6.12.5 does not properly destroy a keyring that is not instantiated properly which allows local users or remote attackers to cause a denial of service (kernel oops) via a keyring with a payload that is not empty which causes the creation to fail leading to a null dereference in the keyring destructor.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 4
  • Red Hat Enterprise Linux 4
  • Oracle Linux 4
Class:
vulnerability
Reference(s):
  • CVE-2005-2099
Product(s):