New Search

Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.12.1 as used in GPdf kdegraphics KPDF CUPS pdftops and teTeX might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.

oval:org.mitre.oval:def:9536

Integer overflow in the ObjectStream::ObjectStream function in XRef.cc in Xpdf 3.x before 3.02pl4 and Poppler before 0.12.1 as used in GPdf kdegraphics KPDF CUPS pdftops and teTeX might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 4
  • Red Hat Enterprise Linux 5
  • Oracle Linux 5
  • Oracle Linux 4
  • Red Hat Enterprise Linux 4
  • CentOS Linux 5
Class:
vulnerability
Reference(s):
  • CVE-2009-3608
Product(s):