New Search

.NET Framework remote code execution vulnerability - CVE-2014-4121 (MS14-057)

oval:org.mitre.oval:def:26757

Microsoft .NET Framework 2.0 SP2 3.5 3.5.1 4 4.5 4.5.1 and 4.5.2 does not properly parse internationalized resource identifiers which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted request to a .NET web application aka ".NET Framework Remote Code Execution Vulnerability."

Family:
windows
Status:
ACCEPTED
Platform(s):
  • Microsoft Windows Server 2008 R2
  • Microsoft Windows Vista
  • Microsoft Windows 8.1
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2003
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows Server 2008
Class:
vulnerability
Reference(s):
  • CVE-2014-4121
Product(s):
  • Microsoft .NET Framework 2.0
  • Microsoft .NET Framework 4.0
  • Microsoft .NET Framework 4.5.1
  • Microsoft .NET Framework 4.5.2
  • Microsoft .NET Framework 3.5.1
  • Microsoft .NET Framework 4.5