New Search

RHSA-2014:1861 -- mariadb security update (Important)

oval:org.mitre.oval:def:27610

MariaDB is a multi-user multi-threaded SQL database server that is binary compatible with MySQL. This update fixes several vulnerabilities in the MariaDB database server. Information about these flaws can be found on the Oracle Critical Patch Update Advisory page listed in the References section. (CVE-2014-2494 CVE-2014-4207 CVE-2014-4243 CVE-2014-4258 CVE-2014-4260 CVE-2014-4287 CVE-2014-4274 CVE-2014-6463 CVE-2014-6464 CVE-2014-6469 CVE-2014-6484 CVE-2014-6505 CVE-2014-6507 CVE-2014-6520 CVE-2014-6530 CVE-2014-6551 CVE-2014-6555 CVE-2014-6559) These updated packages upgrade MariaDB to version 5.5.40. Refer to the MariaDB Release Notes listed in the References section for a complete list of changes. All MariaDB users should upgrade to these updated packages which correct these issues. After installing this update the MariaDB server daemon (mysqld) will be restarted automatically.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 7
  • Red Hat Enterprise Linux 7
Class:
patch
Reference(s):
  • RHSA-2014:1861
  • CESA-2014:1861
  • CVE-2012-5615
  • CVE-2014-2494
  • CVE-2014-4207
  • CVE-2014-4243
  • CVE-2014-4258
  • CVE-2014-4260
  • CVE-2014-4274
  • CVE-2014-4287
  • CVE-2014-6463
  • CVE-2014-6464
  • CVE-2014-6469
  • CVE-2014-6484
  • CVE-2014-6505
  • CVE-2014-6507
  • CVE-2014-6520
  • CVE-2014-6530
  • CVE-2014-6551
  • CVE-2014-6555
  • CVE-2014-6559
Product(s):
  • mariadb