New Search

RHSA-2014:1999 -- mailx security update (Moderate)

oval:org.mitre.oval:def:28385

The mailx packages contain a mail user agent that is used to manage mail using scripts. A flaw was found in the way mailx handled the parsing of email addresses. A syntactically valid email address could allow a local attacker to cause mailx to execute arbitrary shell commands through shell meta-characters and the direct command execution functionality. (CVE-2004-2771 CVE-2014-7844) Note: Applications using mailx to send email to addresses obtained from untrusted sources will still remain vulnerable to other attacks if they accept email addresses which start with "-" (so that they can be confused with mailx options). To counteract this issue this update also introduces the "--" option which will treat the remaining command line arguments as email addresses. All mailx users are advised to upgrade to these updated packages which contain backported patches to correct these issues.

Family:
unix
Status:
ACCEPTED
Platform(s):
  • CentOS Linux 6
  • CentOS Linux 7
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
Class:
patch
Reference(s):
  • RHSA-2014:1999
  • CESA-2014:1999-CentOS 6
  • CESA-2014:1999-CentOS 7
  • CVE-2004-2771
  • CVE-2014-7844
Product(s):
  • mailx